Home JGAurora A5 & A3S Modifications & Upgrades

Extrusion stop working after a while

Angelo BettoliAngelo Bettoli Posts: 14Member
edited June 2020 in Modifications & Upgrades
Hello there, I have a problem with the extrusion on my A5 and it's started after I made the SKR 1.3 upgrade.
First I thought that the problem was related to the nozzle and, as it was not so new, I changed it.
Then, as the problem still persist, I changed the PTFE troath and the bowden tube, no improvements.

 At this point I checked the stepper drivers but are well cooled.
So my attention after a lot of checks is now focused on the extruder stepper motor that results very very very hot.
I have this problem after a while because during the printing process, despite the height that I thought it was the primary factor at the beginning.

For example, if I print something like this no problem:


But if I try to print this one:


When the print arrived here:

The extrusion stop to work.
I noticed also a lot of signs on the filament too.

I don't know, with the original board and the "old" Marlin I never had this problem, or atleast, never experienced it.
Is it possible that some of the new parameters (like wave stepping) could rise the temp of the motor?
To configure the SKR and TMC driver in UART mode I followed the Da Hai guide on Youtube.
It seems the same problem as reported here:

Thanks in advance
Post edited by Angelo Bettoli on


  • GandyGandy Posts: 89🌟 Super Member 🌟
    I had a similar problem after upgrading to TMC2208, the current for the extruder was set too high and the motor heated up to a point where the filament would soften and the extruder gear ground into the material. Check the motor temperature regularly during your  print. If the motor heats up, decrease the motor current until the temperature settles somewhere below 35-40 degrees even during long prints. See https://jgmakerforum.com/discussion/comment/4175/#Comment_4175 for more details.

    Thanked by 1Angelo Bettoli
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    Hey Gandy,
    thank you for your hint!
    In fact, I put a bit high value for the extruder driver (900) and I was thinking about that.
    I already had the TMC2208 but only for the X and Y axis.

    I will recompile the firmware with a lower current.
    Thanks :)
  • GandyGandy Posts: 89🌟 Super Member 🌟
    edited June 2020
    If you use octoprint or some other remote control tool you can also change the current midprint and compile the fw once you figured out the correct settings. Can save you a lot of time - if I remember right fine-tuning the current was still quite some lengthy process... A temperature sensor to measure the motor temperature also helped.
    Thanked by 1Angelo Bettoli
    Post edited by Gandy on
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    edited June 2020
    Unfortunatly I never deployed Octoprint despite the fact that I had bought all the necessary  :p
    Just checked the current and it was already set to 800, I will try to lower it to 700 and, in case of skipped steps, I will raise up a bit.

    Thanks again 
    Post edited by Angelo Bettoli on
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    edited June 2020
    Ok so, I did some test starting from 700 and I had to stop the print because the extruder was skipping a lot of steps.
    So then I wanted to try with a more high current (850) to check if it was a problem related to the low voltage but I had the same result as the 800.

    I then tried with 750 and I was immediately surprised by the less noise from the extruder.
    And this is the result compared with the previous attempts:

    Not so bad I can say , and I don't know if there are some skipped layer in the middle or if it was just the Z axis rod a bit too "freely" to move around (there are support but is a bit loose and and tends to go down,

    I will do some other test today :)

    Post edited by Angelo Bettoli on
  • GandyGandy Posts: 89🌟 Super Member 🌟
    Looks like you're heading the right way.

    What do you mean, what tends do go down?
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    Hey there,

    just an update about the actual situation.
    The day after the last post I made current was put down to 740 but, also with this modification, printing stopped as the previous attempts.

    As I bought also a new extruder (Ender3/Anet standard extruder, the red one) I changed the standard one with this new "open air" extruder using a new printer support because the metallic mounting bracket have a small hole in the middle and the stepper doesn't fit in it.

    The assembling was very smooth and in general was looking really solid and a bit more "stronger" than the previous but, as the wise guy said "don't look to appearances".
    In fact, this extruder seems doing less pressure on the filament and this leads on skipping steps.
    Paradox: with the standard PTFE tube the filament stop after 10/15 cm

    Never had any kind of issue about that before that change.
    About that, I resolved using a new one PTFE that I have here around but, only this.

    Thinking that the problem now was the speed (that was actually at 50 mm/s) I tried to lower it a bit to 40 mm/s and the temp of the hotend was set to 215 °C.
    No improvement.

    I tried to loose e tight all the screw on the extruder but the result was always the same.

    I don't really know now if the problem was the upgrade to SKR or if it was a limit of my printer because, until the Covid, I didn't print so much and in this last period  the biggest thing that I made was the face shields.

    As I'm near to build a new printer, the wasn't a wrong buy, but I don't know if make sense to retry the same print with the standard board and the old Marlin version.

    @Gandy I'm using this Z support right now:


    But I will replace them with these others:


  • GandyGandy Posts: 89🌟 Super Member 🌟
    Did you try not using those supports? They add an additional constraint to your lead screws and if they are bent this could lead to worsening of any z-wobble that might already be there. There are a few good videos on YouTube explaining that. Better check if the motor couplers and/or lead screws need to be replaced.
    Thanked by 1Angelo Bettoli
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    Mmmm I didn't tought,and also know about that, I will try without them right now with a test and I let you know.

    Thanks a lot!
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    Ok, just tried but the result was the same.
    This time I didn't noticed any issue with the filament on the extruder (mounted again the standard one).

    Well, I don't really know what to do now.
    I'm not sure that replacing again the board will be the solution.
  • GandyGandy Posts: 89🌟 Super Member 🌟
    I'd say there's nothing wrong in keeping the SKR over the MKS. You do have a recent version of Marlin, right? 
    Did you find out why the replacement extruder had problems pushing the filament through the Bowden tube? Maybe the Feedrate was too high? Did you try lowering the motor current even further? Skipped steps may also occur I'd the current is too high. 
    Thanked by 1Angelo Bettoli
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    edited July 2020
    Yes, was the last one available at that time (1 month ago).
    Right now with the standard extruder I don't have any skipped step.
    I think was only because was not designed for that printer, no other explanations for that.

    The strange thing is that I followed step by step the Da Hai's guide for the SKR + UART, and I'm not using differents things despite him.
    I can now confirm anyway that the extrusion still stopping on the same height everytime.
    Post edited by Angelo Bettoli on
  • GandyGandy Posts: 89🌟 Super Member 🌟
    When extrusion stops, does this mean the extruder motor stops or is it the filament that is not pushed forward any more? When you pull back the filament a bit, are there any grinding marks on it from the extruder gear?
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    edited July 2020
    Most of the time there are marks on the filament inside the extruder, but it doesn't seems a problem from the extruder.
    I have a similar issue also when I have to load the filament, also with the previous board, when it's on the hotend seems that the speed is too high but, also here, nothing was changed.

    P.s.: I have already changed throat and nozzle a couple of times in this la period
    Post edited by Angelo Bettoli on
  • GandyGandy Posts: 89🌟 Super Member 🌟
    Marks on the filament are ok, as long as there are only equidistant slight grooves perpendicular to the direction of movement. 
    If the motor gets too hot, the filament would soften to a point where the teeth of the extruder gear grind away on the filament, leaving a circular mark, this may well take away half of the filament diameter. If the removed material builds up on the gear this may also lead to inconsistent extrusion. If you feel this happened in the past you may want to disassemble the extruder to clean it out. Watch out for the steel ball inside the filament run-out sensor, though, it tends to jump away.
    Make sure to take pictures during disassembly so you later know how to reassemble.
    Thanked by 1Angelo Bettoli
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    No no, aren't the standard mark made by the teeth of the stepper, it could be like you are saying (motor too hot):

    The sensor still have the "clacky" sound, but also you can feel it when you try to put in the filament.
    But most of the time it's like if the filament can't be pushed out from the hotend, so the filament result like if it was "eated" a bit.

    Right now I'm printing the Charlotte valve (complete set) as it require a lot of time and because have a good height.

  • Angelo BettoliAngelo Bettoli Posts: 14Member
    edited July 2020
    After 3 hours and 45 min the filament stop extruding correctly.
    As you can see, it's like if it was crumpled on itself:

    Everytime then when I try to get them out it breaks and I have to disassemble the bowden tube.

    Just for info, the motor was not hot, only out of scale  :D
    I don't know if buying an HT stepper can have some sense.

    In addition, on the filment that it was in the hotend looks ok:

    Post edited by Angelo Bettoli on
  • michalko99michalko99 Posts: 153Member, 🌟 Super Member 🌟
    hi. what filament is it?PLA?If it keeps breaking upon some bending, it is degraded by air moisture. 

    Is your fan running?I mean that small, which runs all the time when printer is powered. If not, or heatsink is dusty, you might have heatcreep issue.Check temperature of hotend heatsink fins after a while
    Thanked by 1Angelo Bettoli
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    edited July 2020
    Hi @michalko99, thank for your reply.
    Yeah it's PLA and it's relatively new (new brand released not so far and bought a couple of months ago).
    It's breaking because still stuck on the extruder so I have to force it to come out, not during the printing process.

    Anyway the fans are running fine (both) and I checked the heatsink status just a month ago when I disassembled all the hotend parts.
    Didn't saw anything strange and, I tried also to check the temperature of the entire block (nozzle, heater and heatsink) and if I remember on the heater was a bit smaller than the one reported on the screen.
    The "laser gun" isn't so precise so, I think that was on the normal range.

    I can also try in this case to raise the extrusion temp to 220/225 °C and see if the problem is related to the temps.
    Post edited by Angelo Bettoli on
  • Angelo BettoliAngelo Bettoli Posts: 14Member
    Hello everyone,

    aaaaaand, in the end, I finally fix it!

    The problem was the retraction or the retraction speed.
    I had 6.8 for retraction and 110 mm/s on rtr speed so, I tried to put both value on "standard" at 4 and 75.

    It woked!

    Of course, now I have to do some test for stringing and so on but, at least, I found what that cause the issue.

    Thank you for the help :)
  • GandyGandy Posts: 89🌟 Super Member 🌟
    Good to hear you fixed it  :)

    I never tried to change the FW limit to the retraction speed and always used the maximum speed. For optimizing retraction length however I learned to like FW retraction which allows to change the retraction settings midprint and get immediate feedback.
    Thanked by 1Angelo Bettoli
Sign In or Register to comment.