Home JGAurora A5S, A1 & A3S-V2 Getting Started & Troubleshooting

Y Layer Shifting - Only on some prints

Hey all!

I am still newer to printing after a friend introduced me to it. I am loving it ..... when it works.

I am at the point of frustration and want to sell my printer for another mfg because I have a new printer that's having issues but help has been limited and I hate the idea of having to buy parts for a brand new printer.

My Issue:
So I have been trying some prints and I am seeing Y layer shifting early on. I have a few that had a single Y later shift but it was much later in the prints but not at the same point, so no consistency.

Following the JG Wiki I checked

  • the bearings and it seems to slide fine without issue, no sticking or anything.
  • I also tightened up the bed belt a bit but not over tight as it was a bit loose.
  • I did notice a bit of fraying on one section of the belt but it doesn't seem to be damaged at all.
  • I also checked the gears and they seem to be fine as well.
  • I also adjusted the "print speed" settings in Cura and tried some additional settings like jerk control etc.
  • Tried different prints that were similar but not the same, to remove doubt of the individual print.
  • I even tried rotating the print to see if I would get different results.

After all of this, I tried another print and still seeing the first few layers shifting. I tried printing a Benchy and it came out fine, so I am really not sure where to go from here. As mentioned, super frustrated because I am not seeing any consistency. Any help would be very welcomed, please see pics for more detail on what I am seeing.

Thx







Comments

  • Samuel PinchesSamuel Pinches Posts: 2,950Administrator

    Welcome @CO2 ... sounds very frustrating indeed. Which firmware are you using on the printer?

  • CO2CO2 Posts: 6Member

    Thx Sam for the welcome. I am using the community firmware, the latest version, I believe it's 2.0H or something like that.

  • Samuel PinchesSamuel Pinches Posts: 2,950Administrator

    @CO2 I agree that should should not be seeing this issue with the latest community firmware, especially not on a new printer. I would suggest to perhaps try the factory firmware just to eliminate that as a possibility, but I would say you should contact the JGMaker support for suggestions. It doesn't make sense to me, as you have eliminated all the possible causes I can think of.

  • CO2CO2 Posts: 6Member

    That's what I was kind of thinking. I have seen you mention this in other posts as well just to rule out software over hardware.

    Just to make things even more interesting. I printed this last night and it's pretty damn flawless overall.
    So confused here.

    I have ordered some new bearings as well just in case I may need them, but that's going to be my worst-case option.


  • Samuel PinchesSamuel Pinches Posts: 2,950Administrator
    edited May 26

    All it takes is one bad bearing ... but it's very hard to diagnose when these are intermittent problems. I would suggest record video so you can reply (and listen to audio) when a shift happens, but that may be difficult to do.

    Post edited by Samuel Pinches on
  • CO2CO2 Posts: 6Member

    I have reloaded the stock firmeware and retrying a previously failed print. So far so good but its not over yet.
    Will update with the outcome :)

  • michalko99michalko99 Posts: 122Member, 🌟 Super Member 🌟

    Are you using your own acceleration and jerk settings in CURA? Y axis is very heavy and if those 2 settings are set too high, axis cannot decelerate that fast. This happens especially on bigger parts, when axis can reach full speed and then need to slow very fast to change direction

  • CO2CO2 Posts: 6Member

    I am using just what was recommended in the Wiki for those. I have tried having them enabled and disabled as well just to see. Made no difference.

    However, reverting back to the stock firmware seems to have resolved it. Not sure if it is chance or not but I have done 2 larger prints, that on the community firmware failed, they are both printing great.

  • michalko99michalko99 Posts: 122Member, 🌟 Super Member 🌟

    by looking on your photos, I spotted that stepper drivers are onboard. Same I had on my crappy Da Vinci Pro until I taken out everything and put there MKS GENl with TMC2208.

    My bad..I was thinking about thermal problems, but after checking this motherboard, drivers are cooled from bottom..

    Maybe Samuel Pinches can help you with speeds, by comparison of stock vs community firmware. I have only A5

    Thanked by 1CO2
Sign In or Register to comment.