Home JGMaker Magic

Extruder driver not working?

MarcoMarco Posts: 2Member

Hi Everyone,

I'm having a problem with my magic printer, and I'm unable to identify what is causing it exactly. :/

The situation is as follows:

  • Got the printer second hand with some problems, found the 3D Printer had a clogged nozzle due to the bowden tube not being fully seated, so I cleaned and rebuild it.
  • Tried some test prints, but they had alot of stringing and some underextrusion. Playing with retraction parameters in CURA didn't seem to change much to the prints.
  • While in the process of changing the parameters, the extruder motor stopped working.
  • Switched the x- and extruder-motor, switched the cables on the mainboard and both again, and found both cables and motors work perfectly with the x-driver on the mainboard.
  • I determined the extruder driver to be faulty, so I ordered an original replacement mainboard from JGAurora.
  • Wired up the new mainboard and powered up the printer, but it had the exact same issue. :|
  • I flashed the original .hex firmware succesfully, but nothing changed.
  • Flashed the updated firmware by DaHai succesfully, but still the extruder didn't work.

I don't know what to look for next, does anyone have an idea what might cause the problem?
First I thought it was a hardware issue, then a software issue, but both seem to be working fine... :/

Many thanks in advance,
Marco

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,967Administrator
    edited July 19

    Welcome @Marco
    Things to check:

    • Is the extruder motor skipping steps? Or grinding filament?
    • Is the friction in the bowden tube too high - perhaps it is kinked or squished? If you disconnect the extruder motor and push filament by hand down the tube (with the nozzle hot), do you encounter resistance?
    • What print settings (speed, temp etc) do you use?
    Thanked by 1Marco
    Post edited by Samuel Pinches on
  • MarcoMarco Posts: 2Member

    Thanks for the quick reaction @Samuel Pinches,

    I figured out wat was wrong finally, turns out that the extruder wasn't allowed to move because of a low nozzle temperature.
    I feel very stupid for not realising this before, but it explains all the "issues" I was having. :|

    If I'd tested printing from an sd-card before I wouldn't have a spare mainboard lying around haha... :#
    In my defence, the printer didn't tell me that this was the issue. I tried it on my ender 3 and it nicely gives a warning so yeah...

    Anyway, thanks for helping. I'll continue tuning the printer to improve the retraction. I can't seem to get this dialed in properly yet. I don't know if this should be put in another thread, but what retraction settings would you suggest? Right now I use the stock 'normal' profile from cura, with 5mm retraction at 50mm/s.

    I also tested the filament drag, but it doesn't seem abnormal. It takes little force to move it in and out of the bowden tube. Purging through the nozzle takes definitely takes some more force but it seems okay (could previous grinding of the nozzle against the bed cause a smaller nozzle hole and thus maybe too much purging drag?).

    The extruder gear isn't grinding the filament when pushing, it does leave some teeth marks however but the filament doesn't slip. How would I test if it is skipping steps?

    Lastly I read about grounding the USB port, is this recommended? So far I have no issues using my old laptop.

    Thanks again for the help, it is greatly appreciated. :)

  • Samuel PinchesSamuel Pinches Posts: 2,967Administrator
    edited July 19

    I'm glad to hear that you've found the solution :)

    Retraction settings vary, probably 4-5mm or so is very reasonable?

    You can put something physically on the back end of the motor shaft, or dot it with a permanent marker. If it stutters back and forward (normally you would hear this too) you can tell if it is skipping steps.

    No need to worry about grounding the USB on the JGMaker magic.

    Thanked by 1Marco
    Post edited by Samuel Pinches on
Sign In or Register to comment.