Home JGAurora A5S, A1 & A3S-V2 Getting Started & Troubleshooting

Cannot print of SD card

Hi I just recently got my Jg Aurora A5S and it will not print off an SD card. I have successfully printed while connected to my computer but if I slice a model in Cura or Jgcreat then send it to my SD card it will not work. My printer will register the SD card and I can click my file and the screen will change to the printing page as if it’s about to start printing. But it will not move at all even when the extruder and build plate have come up to temperature. I have tried different slicing softwares and different SD cards but I am only successful through connect right into my computer. And my computer will only register that a printer is connected in Jgcreat not Cura.
Any help would be greatly appreciated.


  • Samuel PinchesSamuel Pinches Posts: 2,997Administrator
    @Zane welcome!

    You can try printing using Pronterface.

    Otherwise, I recommend to contact JGaurora


  • Richy_TRichy_T Posts: 142🌟 Super Member 🌟
    edited January 2019
    Try a different SD card. I was having the same thing and then the card corrupted, needing a reformat. I tried a different card and no issues at all.

    For what it's worth, I had no luck printing from Cura. It would heat and then print about 50mm on the bed then stop. I was using an overly-long cable though.
    Post edited by Richy_T on
  • ZaneZane Posts: 6Active Member
    I actually have tried a brand new SD card however when I load a file and insert it into the printer nothing comes up.
    When I press the print button it opens up the SD card but it’s show that it is empty
    But when I plug it back into my printer it shows that there is indeed still a file on there.

    Any thoughts?
  • ercan_özerercan_özer Posts: 1Member

    This problem exists because the sd card does not see the file format loaded into it. the stl format may be corrupted. Try another stl file
  • Richy_TRichy_T Posts: 142🌟 Super Member 🌟
    It turns out that it may have been the white SD to USB thing that came in the box as it's now completely dead. Fortunately, I have a few spares lying around. Though I'm moving towards octoprint. Moving SD cards around is for the birds.
  • MarkMarcumMarkMarcum Posts: 19Member
    I just got my A5S printer and the sd card it doing the same thing. what is the fix for that problem? Also i cant hook it to my computer. it says it does not have the correct driver. where can i get the correct driver? i have tried looking online with no luck. This is very frustrating, i cant print anything at all. 
  • Samuel PinchesSamuel Pinches Posts: 2,997Administrator
    edited March 2020

    Many of the early SD cards they sent were corrupted. I recommend formatting the SD card and try again, or try another SD card (32GB or less).

    Mac CH340 serial drivers are here. PC CH340 serial drivers are here. On a mac running high-sierra, I had problems with those mac drivers, and I had a more reliable connection with the mac drivers available for purchase (unfortunately… not free, but someone gotta eat) here.
    Thanked by 1MarkMarcum
    Post edited by Samuel Pinches on
  • MarkMarcumMarkMarcum Posts: 19Member
    I did try formatting and trying again. Perhaps i need a new SD card then? ill order one right now. thank you so much for the help. i dont know where you got the drivers from but thank you so much. 
Sign In or Register to comment.