Home JGAurora A5 & A3S Modifications & Upgrades

Problems after TMC2130 drivers installation.

Hi guys! Can you, please, help me with an advice for the below matter: I have a JG Aurora A5 and until few days ago everything worked perfect. I've tried to change the filament and I've broke the nozzle thermistor and this led to nozzle and bed channel on the mainboard malfunction, the sensors indicating wrong values?

Today I changed the mks gen l v1.0 mainboard with a new one and, with this occasion, I've changed also the drivers for X and Y with TMC 2130, following this video from DaHai Zhu: https://www.youtube.com/watch?v=Ul2rboKmc6g

I used the community firmware for this new mainboard and I changed the drivers state (true, false), like Da Hai DaHai Zhu indicates in his video.

You can see my problem in this video attached, because it explains better the situation:


Do you have any clue that can help me solving this problem with X and Y axis movement?

Thanks in advance!


  • Claudiu84Claudiu84 Posts: 2Member
    Update: I've forgot to remove the jumpers bellow the 2130 drivers  . I've removed them now, but on the X and Y axis, when I press to move step by step, it is doing this, but only 2 or 3 times, and after that it doesn't move anymore. The Vref is 0.15V when the mainboard is powered with 5V. It is possible to have damaged the 2130 drivers or is an adjustment issue?

Sign In or Register to comment.