Home JGAurora A5S, A1 & A3S-V2 Modifications & Upgrades

Current Firmware Status - Update Dec 1 2019

Samuel PinchesSamuel Pinches Posts: 2,997Administrator
edited December 2019 in Modifications & Upgrades
This is just a short update to inform people of the current status of the firmware for the A5S and A1.

At the moment the builds I have prepared on https://firmware.jgaurorawiki.com are the latest available ready to use.

If you want to build firmware from source my builds were broken by some recent library changes, and will not produce a working build. :( So don't use my github repo for the moment!

I've updated the full marlin 2.0 vscode build guide here. But in a nutshell, to build your own working firmware at the moment, you can:
  1. Clone the marlin 2.0 bugfix branch here.
  2. Copy the configuration.h and configuration_adv.h files from here for your printer, and replace the files in here with those.
  3. Open the platformio.ini file in the root directory here, and change the default_envs from megaatmega2560 to jgaurora_a5s_a1
  4. Try compile the build as per the previous instructions here.
  5. Compiled bin will be in \Documents\GitHub\Marlin\.pio\build\jgaurora_a5s_a1\
  6. Copy file to SD card, and restart printer to flash.
For full instructions, see my marlin 2.0 build guide here.

I've attached compiled builds to this post if you would like to try these builds, using the very latest build of marlin 2.0. They are untested by me but should work - hence "BETA".

Thanked by 2aestrems eyes
Post edited by Samuel Pinches on


  • eyeseyes Posts: 70🌟 Super Member 🌟
    Thank you Samuel. I need to make some changes to make BL Touch work for me. Are the files here https://github.com/MarlinFirmware/Marlin/tree/bugfix-2.0.x/config/examples/JGAurora the ones you used to make your builds? I just wanted to make sure since they are labeled as examples. I have tried changing mine since the new version of marlin 2.0.x has changed the names of what some settings are called, but I am getting all kinds of errors compiling.
  • Samuel PinchesSamuel Pinches Posts: 2,997Administrator
    edited December 2019
    Yes - I submitted those to the Marlin team. They change things all the time, so they continually are (or at least normally are) updating those files to match the current variable names. If you post the errors here maybe we can debug, or perhaps message me and we can try a teamviewer session.
    Post edited by Samuel Pinches on
  • eyeseyes Posts: 70🌟 Super Member 🌟
    Thank you. I'm going to start with your config.h, adv.h and pins file and change what I need and see if that works. I was able to successfully compile  them withiut changing anything.  I'll keep you 
     posted. Hopefully it's just some old 2.0 junk that's causing the errors. There are a lot of errors that keep repeating. I remember one that said servo0_timer_num 8 was redefined. Whatever that means. Not sure if that 0 was after servo. 
  • eyeseyes Posts: 70🌟 Super Member 🌟
    I successfully compiled and was able to upload my new build. I had to use the ST Link. My SD reader is still not working for uploads. I haven't had a chance to test it but at least my board will now boot! It's strange that this started happening. I changed one thing then started getting the errors when uploading the new build. I know the current version of Marlin 2.0.x has changed since your build and guide with 2.0D, but all the files I was using were on my local drive and I never updated them until recently. I still had errors even though it finished building so I have to see if bltouch still works because I think one of the errors was related to that. I'll post them later. 
  • Samuel PinchesSamuel Pinches Posts: 2,997Administrator
    Awesome work! 🥳 - if you can upload your builds (with and without boot loader) I’m sure others would be interested too 😃
  • eyeseyes Posts: 70🌟 Super Member 🌟
    My builds include BLTouch and the BMG extruder - the same things Frezap originally had with his BLTouch build. If anyone is interested I will upload them.

    Regarding the errors, it looks like they were more of notifications, even though they kept repeating during the build. One was regarding Servo0_timer_num_8 which anyone not using BLTouch shouldn't have.

    The other was "STM32_XL_DENSITY" redefined. Whatever that is I guess redefined is not an error. Its part of the pins file. I have attached a screenshot of it and will paste some of my build output showing that. Samuel maybe you will know what it means!  

    FYI - just noticed on they are called warnings not errors.
    Here are some examples of the warnings. There are a lot more than this.

    Marlin\src\lcd\menu\../../inc/../pins/stm32/pins_JGAURORA_A5S_A1.h:38:0: warning: "STM32_XL_DENSITY" redefined
     #define STM32_XL_DENSITY

    In file included from Marlin\src\lcd\menu\../../inc/../pins/pins.h:487:0,
                     from Marlin\src\lcd\menu\../../inc/MarlinConfig.h:32,
                     from Marlin\src\lcd\menu\../ultralcd.h:24,
                     from Marlin\src\lcd\menu\menu.h:24,
                     from Marlin\src\lcd\menu\menu_ubl.cpp:31:
    Marlin\src\lcd\menu\../../inc/../pins/stm32/pins_JGAURORA_A5S_A1.h:38:0: warning: "STM32_XL_DENSITY" redefined
     #define STM32_XL_DENSITY

    Compiling .pio\build\jgaurora_a5s_a1\src\src\libs\nozzle.cpp.o
    In file included from Marlin\src\lcd\../inc/../pins/pins.h:487:0,
                     from Marlin\src\lcd\../inc/MarlinConfig.h:32,
                     from Marlin\src\lcd\ultralcd.h:24,
                     from Marlin\src\lcd\ultralcd.cpp:33:
    Marlin\src\lcd\../inc/../pins/stm32/pins_JGAURORA_A5S_A1.h:38:0: warning: "STM32_XL_DENSITY" redefined
     #define STM32_XL_DENSITY

    In file included from Marlin\src\libs\L6470\../../inc/../pins/pins.h:487:0,
                     from Marlin\src\libs\L6470\../../inc/MarlinConfig.h:32,
                     from Marlin\src\libs\L6470\L6470_Marlin.cpp:27:
    Marlin\src\libs\L6470\../../inc/../pins/stm32/pins_JGAURORA_A5S_A1.h:38:0: warning: "STM32_XL_DENSITY" redefined
     #define STM32_XL_DENSITY

    In file included from Marlin\src\libs\../inc/../pins/pins.h:487:0,
                     from Marlin\src\libs\../inc/MarlinConfig.h:32,
    Compiling .pio\build\jgaurora_a5s_a1\src\src\module\delta.cpp.o
                     from Marlin\src\libs\buzzer.cpp:23:
    Marlin\src\libs\../inc/../pins/stm32/pins_JGAURORA_A5S_A1.h:38:0: warning: "STM32_XL_DENSITY" redefined
     #define STM32_XL_DENSITY

Sign In or Register to comment.