Home JGAurora A5 & A3S Modifications & Upgrades

Issues When upgrading to the custom firmware

i tried upgraded to the custom firmware recently. i was able to get the firmware on the main motherboard perfectly fine, but ran into some issues when i tried to do the LCD screen. i can no longer get the screen to display anything, but all the lights show up when the printer is turned on. i did turn the printer off when we first tried to flash it, but nothing seemed to happen. 

i'm hoping i don't need to buy a new LCD board, but will if i need to. i would just like to be able to print without having a computer strapped next to the printer.


  • Jacob_VaughanJacob_Vaughan Posts: 12Active Member
    so, i was able to figure out what was wrong. the power cable to the LCD board wasn't in fully. although now we can't home the printer without the motors going to far past the home. any ideas on how to fix this? 

    due note that i haven't set the mesh bed level yet. i just tried using the homing command withing the firmware
  • Samuel PinchesSamuel Pinches Posts: 2,997Administrator
    You can test the endstop functionality using gcode command M119 in pronterface. I would do that first.

  • Jacob_VaughanJacob_Vaughan Posts: 12Active Member
    all of the sensors where triggering except the bed's. not sure if that's fixable or i need to buy new ones
  • Samuel PinchesSamuel Pinches Posts: 2,997Administrator
    Switches are mechanical things - first I would check the wiring is good. If you have a multimeter, you can use continuity mode to test the switch, check wiring is continuous etc.
    Thanked by 1Jacob_Vaughan
  • Jacob_VaughanJacob_Vaughan Posts: 12Active Member
    turns out we plugged the wire into the wrong port. once we switched it it worked fine.
Sign In or Register to comment.